http --- HTTP 模�¶
æº�代ç �: Lib/http/__init__.py
http 是一个包,它收集了多个用于处ç�†è¶…æ–‡æœ¬ä¼ è¾“å��议的模å�—:
http.client是一个底层的 HTTP �议客户端;对于高层级的 URL 访问请使用urllib.requesthttp.server包�基于socketserver的基本 HTTP �务类http.cookies包�一些有用�实现通过 cookies 进行状�管�的工具http.cookiejar�供了 cookies 的�久化
http 模å�—还定义了下列枚举æ�¥å¸®åŠ©ä½ ä½¿ç”¨ http 相关的代ç �:
- class http.HTTPStatus¶
在 3.5 ç‰ˆæœ¬åŠ å…¥.
enum.IntEnumçš„å�类,它定义了组 HTTP 状æ€�ç �,原ç�†çŸè¯ä»¥å�Šç”¨è‹±è¯ä¹¦å†™çš„é•¿æ��述文本。用法:
>>> from http import HTTPStatus >>> HTTPStatus.OK HTTPStatus.OK >>> HTTPStatus.OK == 200 True >>> HTTPStatus.OK.value 200 >>> HTTPStatus.OK.phrase 'OK' >>> HTTPStatus.OK.description 'Request fulfilled, document follows' >>> list(HTTPStatus) [HTTPStatus.CONTINUE, HTTPStatus.SWITCHING_PROTOCOLS, ...]
HTTP 状æ€�ç �¶
已支æŒ�的,IANA 注册的状æ€�ç � 在 http.HTTPStatus ä¸å�¯ç”¨çš„æœ‰:
å�Œå—æ¯�代ç � |
æ˜ å°„å�� |
详情 |
|---|---|---|
|
|
HTTP/1.1 RFC 7231, 6.2.1 节 |
|
|
HTTP/1.1 RFC 7231, 6.2.2 节 |
|
|
WebDAV RFC 2518, 10.1 节 |
|
|
用于指定æ��示 RFC 8297 çš„ HTTP 状æ€�ç � |
|
|
HTTP/1.1 RFC 7231, 6.3.1 节 |
|
|
HTTP/1.1 RFC 7231, 6.3.2 节 |
|
|
HTTP/1.1 RFC 7231, 6.3.3 节 |
|
|
HTTP/1.1 RFC 7231, 6.3.4 节 |
|
|
HTTP/1.1 RFC 7231, 6.3.5 节 |
|
|
HTTP/1.1 RFC 7231, 6.3.6 节 |
|
|
HTTP/1.1 RFC 7233, 4.1 节 |
|
|
WebDAV RFC 4918, 11.1 节 |
|
|
WebDAV Binding Extensions RFC 5842, 7.1 节(实验性) |
|
|
Delta Encoding in HTTP RFC 3229, 10.4.1 节 |
|
|
HTTP/1.1 RFC 7231, 6.4.1 节 |
|
|
HTTP/1.1 RFC 7231, 6.4.2 节 |
|
|
HTTP/1.1 RFC 7231, 6.4.3 节 |
|
|
HTTP/1.1 RFC 7231, 6.4.4 节 |
|
|
HTTP/1.1 RFC 7232, 4.1 节 |
|
|
HTTP/1.1 RFC 7231, 6.4.5 节 |
|
|
HTTP/1.1 RFC 7231, 6.4.7 节 |
|
|
Permanent Redirect RFC 7238, Section 3 (Experimental) |
|
|
HTTP/1.1 RFC 7231, 6.5.1 节 |
|
|
HTTP/1.1 Authentication RFC 7235, 3.1 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.2 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.3 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.4 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.5 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.6 节 |
|
|
HTTP/1.1 Authentication RFC 7235, 3.1 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.7 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.8 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.9 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.10 节 |
|
|
HTTP/1.1 RFC 7232, 4.2 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.11 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.12 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.13 节 |
|
|
HTTP/1.1 Range Requests RFC 7233, 4.4 节 |
|
|
HTTP/1.1 RFC 7231, 6.5.14 节 |
|
|
HTCPCP/1.0 RFC 2324, Section 2.3.2 |
|
|
HTTP/2 RFC 7540, 9.1.2 节 |
|
|
WebDAV RFC 4918, 11.2 节 |
|
|
WebDAV RFC 4918, 11.3 节 |
|
|
WebDAV RFC 4918, 11.4 节 |
|
|
使用 HTTP RFC 8470 ä¸çš„æ—©æœŸæ•°æ�® |
|
|
HTTP/1.1 RFC 7231, 6.5.15 节 |
|
|
Additional HTTP Status Codes RFC 6585 |
|
|
Additional HTTP Status Codes RFC 6585 |
|
|
Additional HTTP Status Codes RFC 6585 |
|
|
HTTP 状æ€�ç �用于报告法律障ç¢� RFC 7725 |
|
|
HTTP/1.1 RFC 7231, 6.6.1 节 |
|
|
HTTP/1.1 RFC 7231, 6.6.2 节 |
|
|
HTTP/1.1 RFC 7231, 6.6.3 节 |
|
|
HTTP/1.1 RFC 7231, 6.6.4 节 |
|
|
HTTP/1.1 RFC 7231, 6.6.5 节 |
|
|
HTTP/1.1 RFC 7231, 6.6.6 节 |
|
|
�明内容�商在: HTTP RFC 2295, 8.1 节(实验性) |
|
|
WebDAV RFC 4918, 11.5 节 |
|
|
WebDAV Binding Extensions RFC 5842, 7.2 节(实验性) |
|
|
WebDAV Binding Extensions RFC 5842, 7.2 节(实验性) |
|
|
Additional HTTP Status Codes RFC 6585, 6 节 |
为了ä¿�æŒ�å�‘å�Žå…¼å®¹æ€§ï¼Œæžšä¸¾å€¼ä¹Ÿä»¥å¸¸é‡�å½¢å¼�出现在 http.client 模å�—ä¸ï¼Œã€‚ 枚举å��ç‰äºŽå¸¸é‡�å�� (例如 http.HTTPStatus.OK 也å�¯ä»¥æ˜¯ http.client.OK)。
在 3.7 版本å�‘生å�˜æ›´: æ·»åŠ äº† 421 MISDIRECTED_REQUEST 状æ€�ç �。
在 3.8 ç‰ˆæœ¬åŠ å…¥: æ·»åŠ äº† 451 UNAVAILABLE_FOR_LEGAL_REASONS 状æ€�ç �。
在 3.9 ç‰ˆæœ¬åŠ å…¥: å¢žåŠ äº† 103 EARLY_HINTS, 418 IM_A_TEAPOT å’Œ 425 TOO_EARLY 状æ€�ç �
HTTP 状�类别¶
在 3.12 ç‰ˆæœ¬åŠ å…¥.
这些枚举值具有一些用于指明 HTTP 状�类别的特�属性:
特�属性 |
表示 |
详情 |
|---|---|---|
|
|
HTTP/1.1 RFC 7231, Section 6 |
|
|
HTTP/1.1 RFC 7231, Section 6 |
|
|
HTTP/1.1 RFC 7231, Section 6 |
|
|
HTTP/1.1 RFC 7231, Section 6 |
|
|
HTTP/1.1 RFC 7231, Section 6 |
用法:
>>> from http import HTTPStatus >>> HTTPStatus.OK.is_success True >>> HTTPStatus.OK.is_client_error False
- class http.HTTPMethod¶
在 3.11 ç‰ˆæœ¬åŠ å…¥.
一个
enum.StrEnumçš„å�类,它定义了一组 HTTP 方法以å�Šç”¨è‹±æ–‡ä¹¦å†™çš„æ��述。用法:
>>> from http import HTTPMethod >>> >>> HTTPMethod.GET <HTTPMethod.GET> >>> HTTPMethod.GET == 'GET' True >>> HTTPMethod.GET.value 'GET' >>> HTTPMethod.GET.description 'Retrieve the target.' >>> list(HTTPMethod) [<HTTPMethod.CONNECT>, <HTTPMethod.DELETE>, <HTTPMethod.GET>, <HTTPMethod.HEAD>, <HTTPMethod.OPTIONS>, <HTTPMethod.PATCH>, <HTTPMethod.POST>, <HTTPMethod.PUT>, <HTTPMethod.TRACE>]
HTTP 方法¶
已支æŒ�的,IANA 注册的方法 在 http.HTTPMethod ä¸å�¯ç”¨çš„æœ‰:
方法 |
æ˜ å°„å�� |
详情 |
|---|---|---|
|
|
HTTP/1.1 RFC 7231, Section 4.3.1 |
|
|
HTTP/1.1 RFC 7231, Section 4.3.2 |
|
|
HTTP/1.1 RFC 7231, Section 4.3.3 |
|
|
HTTP/1.1 RFC 7231, Section 4.3.4 |
|
|
HTTP/1.1 RFC 7231, Section 4.3.5 |
|
|
HTTP/1.1 RFC 7231, Section 4.3.6 |
|
|
HTTP/1.1 RFC 7231, Section 4.3.7 |
|
|
HTTP/1.1 RFC 7231, Section 4.3.8 |
|
|
HTTP/1.1 RFC 5789 |